View Single Post
  #5  
Old 06-01-2020, 02:31 AM
vincococka vincococka is offline
Registered User
 
Join Date: May 2020
Posts: 5
Hi,

the error occurs after I start SecureCRT (after Windows reboot) and it shows following error (please ignore the path in image, I've played little bit with it).
Then I need to configure path to DLL again (which is in SSH2 dialog predefined because it was correctly red from config file during start), and after I've chosen same DLL in same path it starts to read my YubiKey again upon connection.

Regarding permissions to config files - I think that this is absolutely no problem as I just installed SecureCRT and never touched the folder in AppData\Roaming\VanDyke\Config.
Also files content is changing when I reconfigure something.

I have also tried to turn off realtime protection inside Windows internal antivirus - but no change, same behaviour.

You can simulate it even without having yubikey:
1, install from the site bottom YubiKey PIV TOOL command line from https://www.yubico.com/products/serv...drivers-tools/
2, point SecureCRT via SSH2->PKCS11 to DLL in <YUBIKEY_PIV_INSTALLDIR>\bin\libykcs11-1.dll
3, close the application
4, start application
5, connect to any server via SSH ... and there we are - SecureCRT cant find DLL that previously worked allright without any problem

Greets,
J.
Attached Images
File Type: png securecrt-boot-error-no-dll.png (44.5 KB, 118 views)

Last edited by jdev; 06-01-2020 at 07:12 AM. Reason: Don't use external file sharing sites. Click Manage Attachments, and upload your graphics.
Reply With Quote