View Single Post
  #1  
Old 03-19-2018, 01:00 PM
npbrewer npbrewer is offline
Registered User
 
Join Date: Mar 2018
Posts: 1
Exclamation vShell sftp backup for cPanel errors

Hi all,

First time poster.

I recently started a position with a new company that is having cPanel backup transport errors to vShell.

Server information:
Windows Server 2008 R2 Standard
vShell Version: 3.8.4 (x64 build 354)

Our internal cPanel Web/DNS server is configured to do backups to this vShell server nightly.

The sftp user authenticates properly and Actual Backups complete fine but cPanel is unable to prune (remove) old backups and is sending transport notifications daily. Obviously this is problematic as it will fill up the data drive.

------------------------------------------------------------

vShell logs are reporting this error (IPs removed):

2018-03-18 02:03:10 VShellSSH2 conn 3373 x.x.x.x 57310 <internal>\ns03backups - - 0 0 0 0 - - "03373: Received request to start subsystem sftp (Built-in Subsystem)"
2018-03-18 02:03:10 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: SFTP subsystem initialized; remote version is 3"
2018-03-18 02:03:10 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: Sending VERSION packet to remote (3)"
2018-03-18 02:03:10 VShellSSH2 auth 3373 - - <internal>\ns03backups - - 0 0 0 0 - - "03373: Using home directory 'E:\ftproot\ns03backups\' for user <internal>\ns03backups"
2018-03-18 02:03:11 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: Failed to open directory '/ns03backups/2018-03-18/system': The system cannot find the path specified."
2018-03-18 02:03:11 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: Failed to stat file: '/ns03backups/2018-03-18/system' as user: ns03backups System Error: The system cannot find the path specified."
2018-03-18 02:03:11 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: Failed to stat file: '/ns03backups/2018-03-18' as user: ns03backups System Error: The system cannot find the file specified."
2018-03-18 02:03:11 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: ns03backups created directory '/ns03backups/2018-03-18'"
2018-03-18 02:03:11 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: ns03backups created directory '/ns03backups/2018-03-18/system'"
2018-03-18 02:03:11 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: ns03backups changed permissions on 'E:\ftproot\ns03backups\2018-03-18\system\system_files.tar' to '600'"
2018-03-18 02:04:12 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - E:\ftproot\ns03backups\2018-03-18\system\system_files.tar 0 601180160 0 601180160 x.x.x.x 22 "03373: <internal>\ns03backups has accessed 'E:\ftproot\ns03backups\2018-03-18\system\system_files.tar': 601180160 bytes uploaded"
2018-03-18 02:04:12 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - E:\ftproot\ns03backups\2018-03-18\system\system_files.tar 0 601180160 0 601180160 x.x.x.x 22 "03373: Trigger executed command: C:\Windows\system32\WindowsPowerShell\v1.0\powershell.exe -ExecutionPolicy Bypass -NoLogo -NonInteractive -NoProfile -WindowStyle Hidden -File E:\ftpscripts\vShellTrigger.ps1 -strbytes 601180160 -strErrorCode 0 -strIPAddress x.x.x.x -strUploadPath E:\ftproot\ns03backups\2018-03-18\system\system_files.tar -strTime 02:04:12 -strUser <internal>\ns03backups"
2018-03-18 02:04:12 VShellSSH2 sftp 3373 x.x.x.x 57310 ns03backups - - 0 0 0 0 x.x.x.x 22 "03373: SFTP subsystem terminated"

--------------------------------------------------------------

Here is the error being reported by the cPanel backup process:

Unable to prune transport “x.x.x.x”
Unable to remove outdated backup: “Cpanel::Transport::Files::_perms_str2oct” was given an invalid permissions string: 0

--------------------------------------------------------------

As you can see it's attempting to locate old backups and then delete them.

The folders and files it's attempting to locate DO exist.

Can anyone help me figure out what's going on here? Please let me know if there is any other info I can provide to help the troubleshooting process.

Thanks in advance for any help!
Reply With Quote