VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   SecureCRT on the Mac (https://forums.vandyke.com/forumdisplay.php?f=24)
-   -   Cannot connect to anything while on VPN Connection (https://forums.vandyke.com/showthread.php?t=13293)

SecureKomrad 10-19-2018 12:12 PM

Cannot connect to anything while on VPN Connection
 
I run SecureCrt on MacOS 10.13.6.

On macOS , when I connect to one of my customer's VPN's, Secure CRT (Version 8.5.0 (build 1740) ) cannot connect to anything, even localhost ( using localhost and 127.0.0.1 for hostname ). However, Mac terminal or iTerm can ssh to localhost and also hosts on my customer's VPN .


On Ubuntu Linux( running in VM on my Macbook ) however, I can connect to localhost and any host on my customers VPN while connected to the same VPN.

I'm not sure why SecureCrt for Mac is not connecting to anything while it works fine on Linux.

Ideas?

bgagnon 10-19-2018 12:22 PM

Hi SecureKomrad,

What is the specific MacOS?

It's often useful to see trace options output which provides debugging information that may help us better understand the problem that you're experiencing.

To enable trace options output:
  • First, open SecureCRT's main File pull-down menu and select Trace Options. If you open the File pull down menu again you should see a checkmark next to Trace Options, indicating that troubleshooting output is now enabled.
  • Next, connect to the remote machine. With trace options enabled, you will notice debugging information displayed in the terminal window that isn't normally there by default when SecureCRT is attempting to establish a connection, and at certain times throughout the lifetime of the connection.
  • Once the problem occurs, please right-click inside the terminal window and choose Select All, then right-click again and choose Copy to transfer the information to the clipboard.
  • Finally, open a text editor, paste the information from the clipboard into the editor program, and save it as a text file.
Since trace options can contain sensitive information, feel free to send it as an attachment via email to support@vandyke.com. Please reference "Attn Brenda - Forum Thread #13293" in the subject line.

NOTICE: The requested troubleshooting data may include sensitive information (usernames, passwords, publicly-accessible host names or IP addresses, etc.).

Please redact sensitive information that would not be appropriate for email communication prior to sending the requested information.

If there is sensitive information that must be conveyed in order to provide a complete picture of the scenario you're facing, please let us know and we will set up a secure upload mechanism that can be used.

SecureKomrad 10-19-2018 01:59 PM

I'll do this next time. After rebooting my Macbook and reconnecting to my customer's VPN, SecureCRT was able to connect to local host and customer systems.

When the problem occured I had performed these actions:
  • Connect to employer VPN from home network. ( securecrt was working )
  • Disconnect from employer VPN
  • Connect to customer VPN
  • Mac Terminal, iTerm could ssh to customer systems , but SecureCRT would not.
  • SecureCRT would open a tab for the session with a red icon on the tab. It did not connect and there were no error messages, just a blank terminal screen on each tab.
  • I could not close the app, I had to force quit it.

Before the reboot, it may be notable that I could start an Ubuntu virtualbox VM , and SecureCRT could connect to customer systems while the VM was connected to the customer VPN.

I wonder if connecting to 2 different VPN's in succession 'confused' SecureCRT .

Regardless, I've bookmarked this thread and I'll send trace logs if the issue occurs again. Note that I added the macOS version to this thread as well.

bgagnon 10-20-2018 01:37 PM

Hi SecureKomrad,

Thanks for the update.


All times are GMT -6. The time now is 03:38 PM.