VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   Installing SecureCRT 8.3.2 on Debian 9.3 (https://forums.vandyke.com/showthread.php?t=13021)

7ea31d9420 02-15-2018 02:42 AM

Installing SecureCRT 8.3.2 on Debian 9.3
 
Hi folks,

I am trying to install SecureCRT on Debian 9.3.
I can remember that the last time I reinstalled my machine this was a hassle too, but somehow I got it running back then.

When I try to install / run SecureCRT i get warnings that I am missing needed libraries like libssl.so.1.0.0, libcrypto.so.1.0.0 and libpng12. It seems like those are old version of the libraries I currently have installed (libssl.1.0.2, libcrypto1.0.2 and libpng16). I tried to create a symlink so that the installed files are also referencable by the old version names, but when I start SecureCRT it still complains about not having the correct versions.

Any hints on how this can be done?
Why is SecureCRT referencing old versions of libraries?

Thanks!

bgagnon 02-15-2018 08:59 AM

Hi 7ea31d9420,

Quote:

Why is SecureCRT referencing old versions of libraries?

Debian 9.3 is not a supported OS. :)

What version of SecureCRT are you installing?

If using v8.3.x, I may have a workaround for you, please send an email to support@vandyke.com and reference "Attn Brenda - Forum Thread #13021" in the subject line.

7ea31d9420 02-16-2018 12:27 AM

The thing is I already had this running. I just had to reinstall my device and now I can't get it to work.

Ok, if it's not possible to post the solution here (but I don't understand why) I will send you guys an email too.

Thanks,
Thomas

bgagnon 02-16-2018 08:29 AM

Hi Thomas,

I've responded to your email and tried to answer your inquiries to the best of my ability.

focaccio 03-12-2018 07:20 AM

Same issue and question - Problem with Debian 9 install
 
Hi,

I'm a long time user of SecureCRT and love the product.
Unable to install on a debian machince for same reason as this thread.

Is there any guidance as to when this problem will be resolved?

Thanks,
Greg

05:00root@zfrr1 /downloads ? dpkg -i scrt-7.3.7-1034.ubuntu13-64.x86_64.deb
Selecting previously unselected package scrt.
(Reading database ... 160167 files and directories currently installed.)
Preparing to unpack scrt-7.3.7-1034.ubuntu13-64.x86_64.deb ...
Unpacking scrt (7.3.7-1034) ...
dpkg: dependency problems prevent configuration of scrt:
scrt depends on libssl1.0.0; however:
Package libssl1.0.0 is not installed.

dpkg: error processing package scrt (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
scrt
05:00root@zfrr1

ekoranyi 03-12-2018 10:29 AM

Hi focaccia,

Debian is not a currently supported platform, with that being the case we cannot guarantee that SecureCRT will install/run on Debian without issue. The information you provided seems to indicate that libssl1.0.0, which SecureCRT relies on, is not available on your system.

Other customers have reported that using the following steps allowed them to run SecureCRT. This would still be an unsupported configuration but may allow you to run SecureCRT successfully.

1) Download the libssl1.0.0 packager from the "jessie" distro.
https://packages.debian.org/jessie/a...1.0.0/download
e.g.:
64-bit: http://security.debian.org/debian-se...b8u7_amd64.deb
32-bit: http://security.debian.org/debian-se...eb8u7_i386.deb
2) Install the libssl1.0.0 package.
dpkg -i libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb (for 64-bit versions)
dpkg -i libssl1.0.0_1.0.1t-1+deb8u7_i386.deb (for 32-bit versions)
3) If you're installing SecureCRT 8.3, it may also need
to install libpng12.0. As with the libssl1.0.0 library,
you should be able to download libpng12.0 from the
"jessie" distro:
https://packages.debian.org/jessie/a...g12-0/download

...and install it (dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb)
Do these steps allow you to run SecureCRT successfully?

focaccio 05-07-2018 10:02 AM

Yes the "side-load" works:

05:52root@xfrr3 /downloads ? dpkg -i scrt-7.3.7-1034.ubuntu13-64.x86_64.deb
Selecting previously unselected package scrt.
(Reading database ... 206028 files and directories currently installed.)
Preparing to unpack scrt-7.3.7-1034.ubuntu13-64.x86_64.deb ...
Unpacking scrt (7.3.7-1034) ...
dpkg: dependency problems prevent configuration of scrt:
scrt depends on libssl1.0.0; however:
Package libssl1.0.0 is not installed.

dpkg: error processing package scrt (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
scrt
05:53root@xfrr3 /downloads ? wget http://security.debian.org/debian-se...b8u8_amd64.deb
--2018-05-07 07:57:48-- http://security.debian.org/debian-se...b8u8_amd64.deb
Resolving security.debian.org (security.debian.org)... 128.61.240.73, 128.31.0.63, 149.20.4.14, ...
Connecting to security.debian.org (security.debian.org)|128.61.240.73|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1044450 (1020K) [application/x-debian-package]
Saving to: ‘libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb’

libssl1.0.0_1.0.1t-1+deb8u8 100%[==========================================>] 1020K 1.78MB/s in 0.6s

2018-05-07 07:57:49 (1.78 MB/s) - ‘libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb’ saved [1044450/1044450]

07:57root@xfrr3 /downloads ? ls -la | grep libssl
-rw-r--r-- 1 root root 1044450 Mar 29 05:25 libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb
07:58root@xfrr3 /downloads ? chmod 777 libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb
07:58root@xfrr3 /downloads ? ls -la | grep libssl
-rwxrwxrwx 1 root root 1044450 Mar 29 05:25 libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb
07:58root@xfrr3 /downloads ? dpkg -i libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb
Selecting previously unselected package libssl1.0.0:amd64.
(Reading database ... 206778 files and directories currently installed.)
Preparing to unpack libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb ...
Unpacking libssl1.0.0:amd64 (1.0.1t-1+deb8u8) ...
Setting up libssl1.0.0:amd64 (1.0.1t-1+deb8u8) ...
07:58root@xfrr3 /downloads ? dpkg -i scrt-7.3.7-1034.ubuntu13-64.x86_64.deb (Reading database ... 206798 files and directories currently installed.)
Preparing to unpack scrt-7.3.7-1034.ubuntu13-64.x86_64.deb ...
Unpacking scrt (7.3.7-1034) over (7.3.7-1034) ...
Setting up scrt (7.3.7-1034) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
07:58root@xfrr3 /downloads ?

markrakozy 06-29-2019 08:48 AM

Sooner or later....
 
VanDyke is going to have to solve this problem. Ubuntu 18.10 and 19.04 have this problem as well, and a side-load does not seem to work. I wrote to support but got back a response simply encouraging me to try to the side-load. :( I'm not convinced that VanDyke takes Linux users seriously.

bgagnon 06-30-2019 02:57 PM

Hi markrakozy,

There have been many posts in this thread.

Quote:

Ubuntu 18.10 and 19.04 have this problem as well, and a side-load does not seem to work.
What is "this problem"?

As you were informed when you contacted support in April, Ubuntu 19 is not yet a supported OS.

I have added this thread to a feature request in our product enhancement database to add support for Ubuntu 19.x. Should a future release of SecureCRT include this feature, notification will be posted here.

markrakozy 07-02-2019 12:07 PM

The "problem"
 
Hi,

The problem is that people like myself have to use more recent Linux distributions for various reasons (compatibility with other software, features, etc.).

Saying it is "not a supported OS" unfortunately does not help me. I purchased a rather expensive licenses on the basis of my perception that VanDyke was responsive to its customers' needs. I do not view compatibility with recent linux distributions as an esoteric requirement. I can appreciate you cannot test everything, but the latest versions you officially support are over 12 months old.

Thanks

Mark

bgagnon 07-02-2019 03:17 PM

Hi markrakozy,

I am sorry for your inconvenience.

Support for Ubuntu 19.x is under development. If you like, we can let you know in this forum thread when a pre-release is available.

If you prefer direct email notification, send an email to support@vandyke.com and include Support for Ubuntu 19 - Forum Thread #13021 in the subject line or use this form from the support page of our website.


All times are GMT -6. The time now is 04:47 AM.