VanDyke Software Forums

VanDyke Software Forums (
-   General (
-   -   Session font size does not change (

way 12-03-2018 07:45 PM

Session font size does not change

I am using SecureCRT 8.5.2 (x64 build 1799) together with SecureCRT 7.3.5 (x64 build 903). 8.2.5 is the latest has been installed. I am using Windows 7.

After installation I have noticed that the font size on the latest installation is larger that on older one. Both installations are using common shared folder for their session definitions. So, session definitions are exactly the same for both.

When I am changing the session font, it affects only the older installation. The latest one simply ignores any changes I am trying to make.

Any suggestions on how to fix the problem?



bgagnon 12-04-2018 08:45 AM

Hi way,

We are going to need additional, specific info.

First of all, why have the two installations?

In both the scenarios you described do you have one single session only open in the respective versions of SecureCRT?

way 12-04-2018 03:19 PM

Answers provided
Hi Brenda,

Here are the answers:

1. I am using SecureCRT multi-version installation to evaluate how the new version is working. Just to make it clear, the new version is not evaluation version, but is the licensed one.

2. No, both installations are multi-session. Below I am providing the steps of installation, which I did:

a. SecureCRT 7.3.5 (x64 build 903) version was run several opened sessions. The definitions of sessions were placed on shared disk, to allowing me to use the same definitions from the different computers.

b. I installed SecureCRT 8.5.2 (x64 build 1799) and made the license registration. The new installation inherited the existing definitions of the sessions and opened them after start. I noticed that sessions have been started even without completion of passphrase. The passphrase has been set with old installation and the session with old version would not start without entering passphrase with old installation. With the new one I have chosen "Continue without passphrase" and new installation opened all existing sessions, defined in old installation.

c. Thus, I have got both multi tab multi-session installations, where I able to manage the sessions, except the fonts on the new installation got no reaction to the current font size adjustments (Lucida Sans Typewriter with/without Unicode Graphic Characters). Old installation changes the fonts properly, according to the instructions.

Summary: I have security question in the new version, since passphrase can be simply ignored with the new installation. Fonts changes also do not work.

Hope that will clarify the situation.


bgagnon 12-04-2018 03:54 PM

1 Attachment(s)
Hi way,

Hope that will clarify the situation.
Unfortunately, not really. :)

When you say the change does not get made are you referring to not seeing the size change reflected in Session Options?

Or just what you see in the terminal window?

Do you have the exact same sessions open in each version/installation of SecureCRT (simultaneously)?

If so, it sounds like you are expecting the change made on one SecureCRT installation (to one or more sessions) to instantly be reflected in the other installation (in the same sessions already open), is that correct?

If so, that is not going to happen unless you reload the session(s) since the configuration is stored in memory. SecureCRT has to reread the session INI file to know the font has been changed.

If you are reopening the sessions, then you might be running into the issue where the first tab sets the font for all connected tabs (as would have been shown in a dialog similar to below the first time you connected more than one tabbed session).

If I still have missed the mark, please list the explicit steps to replicate the issue. Please be specific, labeling Install1 vs Install2 and Tab1a, Tab1b, Tab1c (on Install1) vs Tab2a, Tab2b, Tab2c (on Install2). (Or some other way of clearly distinguishing between the installations.)

This would likely be much easier via regular email, so feel free to send email to and reference "Attn Brenda - Forum Thread #13327" in the subject line.

way 12-04-2018 06:49 PM

More answers
2 Attachment(s)
Hi Brenda,

I have attached the sessions with exactly the same definitions how they look from the old and the new installations.

You wrote: "If so, it sounds like you are expecting the change made on one SecureCRT installation (to one or more sessions) to instantly be reflected in the other installation (in the same sessions already open), is that correct?"

No! I do realize that I have to re-read the session definition after the font change, but neither the session reopening, nor even restarting new installation of SecureCRT does not help! :mad:

I am using the following sequence to change the font (it does not matter from which particular SecureCRT version: the result is the same, no affect on the new installation and after few attempts on the old one too). All the steps done with running old version in parallel. Old installation was not closed when the new one has been restarted:

New Installation.

1.On the tab with active session select "Session Option" button.
2. At the left panel of the "Session Option" window select "Appearance"
3. At the right side of windows click "Font" button
4. At "Font" window change the font size, say from 10 to 8
5. Complete the change with clicking on "Font" window "OK" button.
6. Do the same on "Appearance" window.
7. On Menu do File>Exit
8. Answer "Yes" on question "Do you wish to disconnect from all sessions?
9. Start SecureCRT new installation again
10. See that the font size change has not been applied in the new installation.

I have tried to restart both installations to refresh session definitions. Now font changes are not applied nether on old and on new installations.

bgagnon 12-05-2018 08:05 AM


10. See that the font size change has not been applied in the new installation.
You "see" this how? By going to Session Options and 10 pt is still reflected as the size?

If so, is Auto Save Options enabled in the Options menu?

If it is, but you don't ever see the change accurately reflected in Session Options, it sounds like you do not have write permissions on your config folder. Can you make any change to sessions that does stick?

way 12-05-2018 04:32 PM


Originally Posted by bgagnon (Post 50544)
it sounds like you do not have write permissions on your config folder. [/I]?

Hi Brenda,

You gave me the perfect hint about the shared folder. I have checked the permission and changed permissions to write once again. It did not resolve the problem. However I understood that the problem is in the shared folder content, which had been copied from the old installation. What I did for the resolution:

1. I made export of the current definitions from the old installation at shared folder.
2. With the new installation running from the local drive I imported those definitions, which I exported during step 1.
3. I have checked how definitions worked with the new installation from local drive. They started to work!
4. I copied whole new installation directory to the shared folder.
5. I have changed the global settings of the new installation, selecting the path to the shared folder, Item 4.

Now everything works from both the new and the old installations.

Thanks for your help!

bgagnon 12-06-2018 08:09 AM

Hi way,

Excellent, I am glad to hear you were able to resolve the issue. Thanks for sharing the steps. :)

All times are GMT -6. The time now is 04:05 AM.