VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   SecureCRT on the Mac (https://forums.vandyke.com/forumdisplay.php?f=24)
-   -   OSX 10.13.2 can not get telnet handler change (https://forums.vandyke.com/showthread.php?t=12977)

blittlej 01-11-2018 07:59 PM

OSX 10.13.2 can not get telnet handler change
 
I have OSX 10.13.2. I have to click on URL's to telnet into applications. I can not get OSX to change is telnet handler (e.i., telnet://x.x.x.x) to change to secureCRT (happens in Chrome and Safari). I have spent hours on it. I have changed the Global.ini file to check telnet handler. I have tried to disable SIP on the mac and put telnet into /usr/bin.

I think if I can force the global.ini file in secureCRT to check the telnet client again it would work. But, no luck.

bgagnon 01-12-2018 07:58 AM

Hi blittlej,

If you need to clear the default handler, you might try these steps (but I don't think they have been verified on High Sierra):
  • Open ~/Library/Preferences/com.apple.LaunchServices/com.apple.launchservices.secure.plist

  • Locate the entry that sets the telnet handler to SecureCRT and delete it; then save.

  • In Terminal, from your home folder, run the following command:
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

  • Now, rerun SecureCRT to register SecureCRT (actually the Url Launcher) as the telnet handler. If the prompt doesn't show up, you may need to set the Check Shell Telnet Command to 00000001.

By "changed the Global.ini file", you mean you made that change referenced above, correct?
D:"Check Shell Telnet Command"=00000000
to
D:"Check Shell Telnet Command"=00000001

I have added this thread to a feature request in our product enhancement database to make it easier to set SecureCRT as the default Telnet handler (url). Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct email notification, send an email to support@vandyke.com and include "Feature Request - Forum Thread #12977" in the subject line or use this form from the support page of our website.

blittlej 01-13-2018 05:45 PM

THAT WORKED!!! You are a god send. I spent hours on this.

blittlej 02-23-2018 08:10 AM

It stopped working.
 
For some reason it stopped working.

I re did all the steps again and it will still not work. Do you have any other suggestions?

bgagnon 02-23-2018 08:26 AM

Hi blittlej,

Were there any changes on the machine between when it was working and when it stopped?

blittlej 02-23-2018 08:32 AM

I do not know if there were any.

I finally got it to work by downloading and installing iterm2 and selecting that as the default telnet handler. Then I rebooted. Then I opened secureCRT and it asked to be the default handler again (yaa!). I glad it is working again. But, hopefully this will give you a clue what changed. :)

atchinson 10-07-2019 10:17 PM

LaunchService case sensitivity
 
I may have found the issue, case sensitivity issue. After changing com.apple.launchservices.secure.plist to it matching proper case from info.plist Bundle identifier within the SecureCRT_UrlLauncher app, clicking on telnet://1.1.1.1 URL’s on webpages in Safari started working properly. So there could be a small bug. I would love to know for sure from your or your teams engineers to confirm.

~/Library/Preferences/com.apple.LaunchServices/com.apple.launchservices.secure.plist

LSHandlerURLScheme String telnet
LSHandlerRoleAll String com.vandyke.securecrt.urllauncher

does not match

./Applications/SecureCRT/Contents/Resources/SecureCRT_UrlLauncher/Contents/info.plist
Bundle identifier String com.vandyke.SecureCRT.UrlLauncher

berdmann 10-11-2019 12:48 PM

Hi atchinson,

Thanks for sharing your findings. I have sent the information over to our product director, along with a request to make it easier to configure SecureCRT as the default telnet handler on macOS.

We will be sure to post here to let you know if improvements are made in a future release.


All times are GMT -6. The time now is 04:00 AM.