VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Scripting (https://forums.vandyke.com/forumdisplay.php?f=14)
-   -   Issue with Example Script Paste (or Send ASCII File) With Echo Flow Control (https://forums.vandyke.com/showthread.php?t=14193)

BOkay80 05-28-2020 04:14 PM

Issue with Example Script Paste (or Send ASCII File) With Echo Flow Control
 
I'm having an issue with the following script.

Example: Paste (or Send ASCII File) With Echo Flow Control

I'm using the ASCII file version.

It does not appear to not like lines of CLI code that requires line to word wrap.

When line that word wraps is pasted, it appears to do the echo but the script doesn't recognize it. The result is the script waiting until the timeout occurs.

Any thoughts on a resolution to this?

berdmann 05-29-2020 12:34 PM

Hi BOkay80,

The Paste (or Send ASCII File) With Echo Flow Control script isn't designed to work with long lines.

Modifying the script might be possible, but it's not clear when cycles will become available for such activity.

It would be helpful to have an example of your specific scenario that shows how a wrapped line appears on your screen when this occurs.

Would it be possible for you to upload and attach a screenshot depicting the screen when this occurs?

Or if you prefer you can send an email to support@vandyke.com with "ATTN: Brittney, Forum Thread #14193

BOkay80 05-30-2020 05:12 PM

Quote:

Originally Posted by berdmann (Post 53608)
Hi BOkay80,

The Paste (or Send ASCII File) With Echo Flow Control script isn't designed to work with long lines.

Modifying the script might be possible, but it's not clear when cycles will become available for such activity.

It would be helpful to have an example of your specific scenario that shows how a wrapped line appears on your screen when this occurs.

Would it be possible for you to upload and attach a screenshot depicting the screen when this occurs?

Or if you prefer you can send an email to support@vandyke.com with "ATTN: Brittney, Forum Thread #14193

Thank you, a fix to the script would be a huge help. I emailed you screenshots.

berdmann 06-01-2020 12:05 PM

BOkay80,

Thanks for sending the requested screenshots! I will follow up with you via email.

BOkay80 07-28-2020 01:58 PM

Hello. Just wanted to check in on this as we may integrate this functionality into our base build. Thank you!

berdmann 07-28-2020 04:20 PM

Hi BOkay80.

We have not yet had the free cycles to troubleshoot this scripting issue.

That being said, I would like to gather some additional information from you regarding the issue.

What version of SecureCRT are you running?

What "Emulation" and "On Resize" settings do you have configured for the session that you are testing with? (Options / Session Options / Terminal / Emulation)

Can you please replace lines 57-64 in the script with the following code? This will add information about the line that was being processed when the script errored and the non-printing line endings that might be choking up the remote.

Code:

        If Not crt.Screen.WaitForString(strLine, 3) Then
            crt.Dialog.MessageBox
                "Sent " & nLineNumber + 1 & " lines, but the last one was " & _
                "not echoed back to SecureCRT within 3 seconds." & vbcrlf & _
                vbcrlf & _
                "Abandoning paste operation." & vbcrlf & _
                "Last line: " & Replace(strLine, vbcrlf, "[CRLF]")
            Exit Sub
        End If

Can you send me a screenshot of the error message that you see after modifying the script with the suggested lines? (You can respond using the email thread that we used previously or you can send a new email to support@vandyke.com with "ATTN: Brittney, Forum Thread #14193" as the subject.)


All times are GMT -6. The time now is 08:46 AM.