VanDyke Software Forums

VanDyke Software Forums (
-   SecureCRT on the Mac (
-   -   SecureCRT v8.5.3 slow, hanging, crash ,beachball (

beasse 03-04-2019 02:45 AM

SecureCRT v8.5.3 slow, hanging, crash ,beachball
I have started to experience that i get the spinning beach-ball when running SecureCRT. First i thought this was because i was using the "log session" and the output was so fast that the program were struggling to keep up.

My Info:
Terminal: SecureCRT + FX:(v8.5.3 Mac)
Computer: MBP(Retina, 15-inch, Mid 2015, OSX Mojave 10.14.3)

Today i experienced it again when logging into a remote linux machine with SSH and i ran the "mtr" command. While doing this you get the option to press "d" to change the display mode and after i do that the terminal window becomes "sluggish".

mtr example:
1. I press "d"
2. The cursor disappear on the window and the mode changes.
3. I press "d" again and the spinning ball appears.
4. Now i am helpless :( and all i can do is wait, but nothing happens.

Log session:
1. Login to network firewall
2. Enable log session (save somewhere)
3. run the debug command (once it starts to spit out a lot i get the beachball), i don't have this problem when using my the terminal on my mac for instance.

Would reinstalling SecureCRT help, what could be the issue?

I have stock SecureCRT with a .ini file to get cisco syntax highlighting and that is pretty much it.

ekoranyi 03-04-2019 10:12 AM

Hi beasse,

I'm sorry to hear you're having trouble. I would like to see if we can narrow down the issue.

Do you only see the "spinning beach-ball" when running the "mtr" command or does it occur at other times as well?

Does this issue only occur after pressing the second "d"? Does it consistently happen, every time?

Does the "beach-ball" eventually go away if you leave SecureCRT running? If so, roughly how long does it take to clear?

beasse 03-06-2019 09:12 AM


As soon the client needs to load some output it starts.
It's like it's "thinking..." and then if i am lucky it stops.

Does not matter if i am logging or not.

ekoranyi 03-06-2019 11:22 AM

1 Attachment(s)
Hi beasse,

Thanks for the additional information.

I would like to see if disabling some authentication methods impacts the behavior you see.

To make this change navigate to:
Options > Edit Default Session > SSH2
Here you will want to disable the GSSAPI authentication method, both Kerberos, and other related Key exchange methods. See the below screenshot for clarification.

After making these changes do you see an improvement in the way SecureCRT behaves?

beasse 03-07-2019 09:18 AM


I disabled that and it still behaves the same way unfortunately.

GSSAPI = disabled

I also unchecked those other things.


beasse 03-07-2019 09:36 AM

I use SecureCRT as a primary terminal program in my work and its quite important this works reliably.

Is there some way to debug this?


ekoranyi 03-07-2019 09:37 AM

Hi beasse,

I'm sorry to hear that did not clear up the issue for you. We will likely need to gather additional, sensitive, data such as memory dumps to get a better picture of what is happening. To help avoid exposing sensitive data in the public forums please send an email to with "Attn: Eric Forum Post 13429" in the subject line to continue the troubleshooting process.

JakeP 05-14-2019 03:48 PM

Any Resolution

Were you able to find a resolution to this issue? I have the exact same problem, and I've tried everything to resolve.


JakeP 05-14-2019 05:45 PM

I found the problem!
I was having this exact same issue. Any time I would turn on terminal monitor on Cisco devices, or try to 'cat' any of my log files on my Linux syslog server, SecureCRT would completely freeze. I would get a beach ball, the CPU would peg, and my fan would go crazy. Usually the only way out of this was to force close the app.

It turns out the problem was that I had keyword highlighting on. As soon as I turned it off for that session, the problem went away. I don't know if this is something that they can address or not. Hopefully so.

For reference, you can enable/disable this for each session here: Session Options > Terminal > Appearance > Highlight keywords Setting that to "none" alleviated the problem for me.

jpellegrini 05-14-2019 05:48 PM

Hi JakeP,

Would you be so kind as to send an email to with "Attn: Jon Forum Post 13429" in the subject line?

I would like to gather some information regarding what you were experiencing and see if we can't get regular expressions working more quickly for you.

All times are GMT -6. The time now is 06:33 AM.