VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   SecureCRT on the Mac (https://forums.vandyke.com/forumdisplay.php?f=24)
-   -   Losing focus from SecureCRT window when touching Touchpad (https://forums.vandyke.com/showthread.php?t=14284)

mcox 09-15-2020 07:42 AM

Losing focus from SecureCRT window when touching Touchpad
 
I'm running 8.7.3 (build 2279) on MacOS 10.15.6. I've begun having problems constantly losing focus in the SecureCRT window if my finger even grazes my MacBook's Touchpad. I don't have Tap To Click enabled so that a touch does not equal a click. I have to actually push on the Trackpad to generate a click. However, if I'm typing in SecureCRT, even if the mouse pointer is also in that window, making any contact with the Trackpad will cause the focus to shift out of SecureCRT and my typing is interrupted. I then have to actually click in the window to regain focus. The focus does not change to another app - I don't know where it goes. SecureCRT is still the foreground app, and its title / menu bar is still being displayed at the top of the screen. It doesn't seem to change focus; it merely makes it "not" focus on on SecureCRT's window. No focus at all, if you will. It's quite maddening as I am having a hard time finishing typing a line without having to click in the window and pick up where it left off. Just tapping the spacebar without lightly grazing the Touchpad is difficult to avoid, let alone all the times my palm grazes it. This is why I have the Tap to Click feature off. I re-enabled it just to see if SecureCRT behaved differently but it didn't. I don't recall ever having this problem previously and have been using it on Mac for many years. Any insight appreciated.

bgagnon 09-15-2020 08:07 AM

Hi mcox,

Our developers are investigating this issue. Should progress be made toward a resolution, or further information be requested, I will post in this thread.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Bug Report - Forum Thread #14284" in the subject line.

Cleo 10-25-2020 01:38 PM

same here
 
let me know updates also

bgagnon 10-26-2020 08:05 AM

Hi Cleo,

As stated in the last post, notification will just be in this forum thread unless you send an email to support. :)

mario41OC 10-31-2020 11:56 AM

Same here!
 
Thank you for posting. I'm having the same issue and, YES, it's incredibly annoying.

I fix would be greatly appreciated.

Mario

carl 03-22-2021 03:05 PM

+1 on this issue
 
Same happening for me as well. Originally I thought I was doing something wrong but clearly this is a real issue that others have noticed as well.


No update yet from support?

berdmann 03-22-2021 03:46 PM

Hi Carl,

What version of macOS are you running SecureCRT on?

Are you running the most recent version of SecureCRT, 9.0.1?

If not, can you please test with 9.0.1 to see if the behavior is persistent with the latest release?

For your convenience the following link will redirect you to install SecureCRT:
https://www.vandyke.com/cgi-bin/rele...duct=securecrt
If the issue is persistent in 9.0.1, would you be willing to run an instrumented build in order to help us troubleshoot this issue further?

2mmy 04-14-2021 05:55 AM

+1 for this issue, very annoying.

I'm running Big Sur 11.2.3 on a Mac Mini 2018 (x86), and SecureCRT v9.0.1 (build 2451).
My MacBook Pro 2020 (13", x86) running Big Sur 11.2.3 and SecureCRT v9.0.1 (build 2451) does NOT have this issue.

Can not be 100% sure, but I think I went from 9.0 beta 3 (or was it 4?) directly to v9.0.1 on my Mac Mini, and did not have this issue on the previous version.

I'm willing to test an instrumented build.

Best regards
Tommy V

bgagnon 04-14-2021 08:42 AM

Hi Tommy,

Please note that Big Sur is not yet supported. Is it Intel? Or M1/ARM?

Regarding the focus issue, we cannot offer instrumented builds through the forums so please send an email to support@vandyke.com and reference Forum Thread #14284 - Focus Issue in the subject line.

2mmy 04-15-2021 12:18 AM

Brenda,

It's Intel (as the x86 above was ment to state).

I will send a mail to support.

Best Regards
Tommy V

bgagnon 04-15-2021 07:00 AM

Hi Tommy,

Ah yes, sorry, missed that.

I have added this thread to a feature request in our product enhancement database to add support for Big Sur/Intel. Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct email notification, send an email to support@vandyke.com and include Big Sur Support - Forum Thread #14284 in the subject line or use this form from the support page of our website.

2mmy 04-27-2021 05:58 AM

Hi,

Regarding the focus issue, I have news.
A reboot of my MacMini last afternoon after 49 days of uptime has corrected the issue for me. At least for now, 23hrs later.
Maybe it's triggered by uptime? SecureCRT is always open on my MacMini, with anything from 2-3 to 15-20 tabs open.

Regards
Tommy V

bgagnon 04-27-2021 07:32 AM

Hi 2mmy,

Thanks for the info. I've forwarded the info to the development team.

bgagnon 05-10-2021 08:40 AM

Hi all,

The developers believe the focus issue that was reported is resolved in a pre-release build.

If you would like to try it, please send an email to support@vandyke.com and reference Mac Focus Issue in the subject line.

If writing us from an email address that is not associated with your download account, please include that email address in the body of the email (since this is how we make pre-release builds available).


All times are GMT -6. The time now is 10:59 AM.