VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   Unable to log session on SecureCRT on Ubuntu (https://forums.vandyke.com/showthread.php?t=12599)

mkrishna 02-03-2017 03:12 PM

Unable to log session on SecureCRT on Ubuntu
 
I recently switched to Ubuntu from Windows. I never had a problem with logging the current session on Windows (7). While running it on Ubuntu and after doing the necessary settings (Session Options -> Terminal -> Log File -> Log file name), I see that the file size is going back to zero when I try to access it.

Is this a known problem on Ubuntu and/or the current SecureCRT release? I tried capturing a "raw log", that didn't work either.

My SecureCRT version ...
Version 8.0.2 (build 1118) - Official Release - June 14, 3016

My Ubuntu version is...
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

bgagnon 02-03-2017 03:24 PM

Hi mkrishna,

Quote:

I recently switched to Ubuntu from Windows. I never had a problem with logging the current session on Windows (7). While running it on Ubuntu and after doing the necessary settings (Session Options -> Terminal -> Log File -> Log file name), I see that the file size is going back to zero when I try to access it.
Please clarify the "I see that the file size is going back to zero when I try to access it" part of the above statement.

First, you *are* enabling logging at some point, correct?

Either Start log upon connect is enabled (in Log File category), or you choose Log Session from the File menu?

If so, are you saying that initially this file shows > 0 bytes while capturing output?

But when you open it in a text editor, it's empty?


Quote:

Is this a known problem on Ubuntu and/or the current SecureCRT release? I tried capturing a "raw log", that didn't work either.
As a note, v8.1 is the current SecureCRT release.

Again, I need clarification of what you mean by "didn't work either" and verification you are enabling logging at some point, not just configuring the log file name. :)

mkrishna 02-03-2017 04:06 PM

The log file is created, the size of the log file increases with the output as expected initially, but only for a few seconds. Then the filesize goes to 0. If the session is disconnected, the file is immediately cleared (filesize goes to 0). This appears to occur when logging to a NFS mount.
Logging to the local harddisk does not appear to have an issue.

Attempting to log a file to a SAMBA mount does not work at all (error about failing to get locks).

bgagnon 02-03-2017 04:28 PM

Hi mkrishna,

Thanks for the clarification.

If your license is eligible for it, you might see what your results are in v8.1.

If the same results, we will need to get some troubleshooting info that may contain sensitive data to investigate the issue further. Please send an email to support@vandyke.com and include "Attn Brenda - Forum Thread #12599" in the subject line.


All times are GMT -6. The time now is 04:57 AM.