VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   SecureCRT on the Mac (https://forums.vandyke.com/forumdisplay.php?f=24)
-   -   SecureCRT 8 build 1055 and Norwegian special characters (https://forums.vandyke.com/showthread.php?t=12304)

gan 03-30-2016 06:31 AM

SecureCRT 8 build 1055 and Norwegian special characters
 
2 Attachment(s)
I i'm currently using SecureCRT 8 Build 1055 and seems like there are some issues with none standard characters. In Norway we got 3 characters that is unique for Norway and if i create a folder in session manager using any of these characters everything seems fine until i close scrt and restart the application. After the restart of the application it seems like all the characters are replaces with the hex value for the ascii code.

Attached is screenshot1.jpg that show a new folder under test which is fine. In screenshot2.jpg this is how it looks after i restarted scrt.

For the record i use a Mac with El Capitan 10.11.4 where everything is setup for English except the number, date/time formats and they keyboard which is Norwegian.

-gan

bgagnon 03-30-2016 08:32 AM

Hi gan,

What is the specific Mac OS SecureCRT is installed on?

What keyboard layout, specifically, do you use?

gan 03-30-2016 12:24 PM

Quote:

Originally Posted by bgagnon (Post 45541)
Hi gan,

What is the specific Mac OS SecureCRT is installed on?

What keyboard layout, specifically, do you use?

The OS is El Capitan 10.11.4 and the keyboard layout is Norwegian.

bgagnon 03-30-2016 01:15 PM

1 Attachment(s)
Hi gan,

Maybe it is something specific to El Capitan OS. I could not replicate it with Yosemite. I could create both sessions and folders with those characters and they remained after quit/restart. See attached.

Outside of SecureCRT, if you create folders using those special characters, what are the results?

gan 03-30-2016 01:57 PM

Quote:

Originally Posted by bgagnon (Post 45543)
Hi gan,

Maybe it is something specific to El Capitan OS. I could not replicate it with Yosemite. I could create both sessions and folders with those characters and they remained after quit/restart. See attached.

Outside of SecureCRT, if you create folders using those special characters, what are the results?

Outside of SecureCRT I have no problem with those characters and i neither have any problems with SecureCRT 7.3.7 and earlier releases using the same version of OS X. This problem started with 8.0 beta and tried with both beta 3, 4 and 5. When i went back to 7.3.7 the problem were gone.

-gan

bgagnon 03-30-2016 02:16 PM

Hi gan,

I have submitted this behavior for investigation by the development team. Should progress be made toward a resolution, or further information be requested, I will post in this thread.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Bug Report - Forum Thread #12304" in the subject line.

bgagnon 04-18-2016 11:25 AM

Hello gan,

What is the exact locale you are using?

If using "Norsk bokmal" for the input language, what are the results with "Norsk nynorsk"?

gan 04-18-2016 11:40 AM

Hello,

I haven't actually tried with Nynorsk, but Nynorsk is actually another language that a very small part of Norway use and it's not really an option to use Nynorsk. That would be for me to use Swedish instead of Norwegian.

If you still want me to try Nynorsk i would have to change the language on my Mac just for the test to confirm if working or not, but as i said not an option to keep Nynorsk.

-gan

gan 04-18-2016 01:03 PM

3 Attachment(s)
I changed to Norwegian Nynorsk now with the same result. I also tried to set every setting to Norwegian since i normally have Preferred Language set to English, but still the same problem. Attached are 3 screenshots that show my language and region settings as well as the keyboard and advanced settings. This works fine for all previous releases of SecureCRT and other applications. The issue with the norwegian characters started with SecureCRT 8 beta. I been using the Mac version of SecureCRT since the first release.

-gan

bgagnon 04-18-2016 01:46 PM

Hi gan,

Thanks for the additional info.

gan 05-31-2016 04:01 AM

Hello again,

Do you have any more info regarding this issue, like are you able to reproduce the problem in your environment? Just curious if I can expect this to be fixed in the next build or in the close future.

-gan

jjh 05-31-2016 08:45 AM

Hi gan.

I checked out bug tracking database and it appears that our
developers are currently working on this issue. I don't
know what the work will entail. We will post something here
if they find a solution to the problem. If you don't see a
post here, feel free to contact us again in a while to get
an update on the status.

Thanks

JJH

jdev 08-12-2016 12:14 PM

A newer version of SecureCRT is available for Mac OS X that should resolve this issue with Norwegian/Chinese/Unicode/etc. special characters.

If you're interested in getting access to a newer version that should resolve the issue, please send email to support@vandyke.com using the email address associated with your VanDyke Software download account (the one you use for downloading SecureCRT installers). Please include as the subject, "ATTN: Forum thread #12304 - SCRT on Mac OS, Unicode fix"

--Jake


All times are GMT -6. The time now is 01:35 PM.