VanDyke Software Forums

VanDyke Software Forums (
-   General (
-   -   Ubuntu Serial Port usage (

teggenberger 10-24-2019 10:35 AM

Ubuntu Serial Port usage
I have a desktop PC running Ubuntu 18.4. The PC has a DB-9 Serial port on the back and i'm trying to connect direct to a piece of hardware console port.

The Port is recognized on Ubuntu as:

teggenbe@teggenbe:~$ dmesg | grep tty
[ 0.000000] console [tty0] enabled
[ 0.801726] 00:02: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A

However, when i try to connect using SercureCRT i see this:

Unable to open serial port /dev/ttyS0:
  Permission denied

I've tried different speeds and 'flow control' but always get the same message.
Is there a setting somewhere i'm missing?
I even tried to add 'sudo' in the pre-connect properties option.


berdmann 10-24-2019 03:24 PM

Hi teggenberger,

SecureCRT makes a call to the system to open the serial port when a serial connection is made. So it is likely that the behavior is a result of a configuration issue on the machine. This theory is also supported by the "Permission denied" error that you are seeing. SecureCRT is not allowed to prohibit or grant access to operating system level functions.

Is your user account a member of the dialout group listed for your console cable?

We had a customer report similiar behavior in the past and he provided the following steps:

1. Confirm that /dev/ttyS0 is member of the dialout group using:

        ls -l /dev/ttyS0
2. Make your user account a member of the dialout group using:

        sudo adduser <username> dialout
3. Reboot using:

        sudo reboot

MelliLewis 09-30-2020 09:41 AM

Hello....I had the option to get the sequential port to work, in any event to some degree. I found that the sequential port must be empowered in the profiles. My machine has two COM ports and a Parallel port in the BIOS. Nonetheless, there is just a single physical COM port and one physical equal port (except if I'm missing something). I empowered one and attempted to interface by means of sequential port. The product is as yet incapable to associate with it. It tossed a mistake saying that I needed to guarantee that the baud rate is right just as have it set to 8-n-1 (8 pieces, no equality bit, 1 stop bit). After some looking, I found that I can arrange the port in this manner by giving

jjh 09-30-2020 12:29 PM

Hello MelliLewis

Your post appears to be incomplete.

Can you tell me more about the nature of the problem you are experiencing?

Which product are you using?

What is the problem that you are trying to solve?

What configuration settings do you have in place?

What is the platform?

Thank you


All times are GMT -6. The time now is 04:20 AM.