VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   Cannot negotiate KEX with 3rd party - "No appropriate prime between 1024 and 1024" (https://forums.vandyke.com/showthread.php?t=13985)

dverbern 11-25-2019 06:33 PM

Cannot negotiate KEX with 3rd party - "No appropriate prime between 1024 and 1024"
 
Hello,

Using VShell 4.4.3 (x64 build 1966), a 3rd party is failing to connect to VShell - seems to be failing during KEX whereby "diffie-hellman-group-exchange-sha256" is selected, but then logs show error:

"The transport was aborted with a disconnect packet: No appropriate prime between 1024 and 1024 is available."

This issue appears to have been occurring for some time, and may date to when I had upgraded our VShell version - but this is the first I'm hearing of this issue from this particular 3rd party.

VShell currently has the following Key Exchange Algorithms checked:

diffie-hellman-group-14
diffie-hellman
diffie-hellman-group
diffie-hellman-group-exchange-sha256

I can indeed see a 'primes.txt' file within the VShell directory on our server, but not sure what to make of its contents.

Can someone please assist me in overcoming this issue?

bgagnon 11-26-2019 07:52 AM

Hi dverbern,

As a note, especially for VShell issues, it is preferred you contact support@vandyke.com directly. Working these issues in the forums involves a lot of overhead. :)

For this issue specifically, please contact us at the above email (Attn Brenda - Forum Thread #13985) as it is related to an intentional change in VShell as of v4.1.1.


All times are GMT -6. The time now is 01:19 PM.