VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   General (https://forums.vandyke.com/forumdisplay.php?f=11)
-   -   Using CTRL+MouseWheel to zoom causes last few lines to be hidden past scroll. (https://forums.vandyke.com/showthread.php?t=13340)

microvb 12-23-2018 06:36 PM

Using CTRL+MouseWheel to zoom causes last few lines to be hidden past scroll.
 
Hello,

I have been experiencing this problem ever since upgrading from the earlier versions of 7.x to 8.5 and was hoping it would just go away.

System Information
OS: Windows 10 Pro
Resolution: 3840x2160 (scaling of icons/text is 150%)
SecureCRT: 8.5.2 x64

The problem I am having is reproducible as it happens on my Laptop and other computers here as well. To reproduce the problem, do the following:

* Open SecureCRT
* Use CTRL+MouseWheel (scroll to zoom in or out, either way)
* Run a command that loads more data than the screen can display at once without scrolling.

If you do the above, what will happen, is where the command prompt should be on return, is hidden behind the bottom of the viewport. You can not scroll down to it because it seems to be flowing outside the range the scrollbar will take you to.

After CTRL+MouseWheel zoom
https://i.imgur.com/CxSBidB.png

As you can see in the above picture, the scrollbar is all the way at the bottom yet the last couple lines up to and including the return to prompt are not visible. You can still type, however you can no longer see what is being typed.

I also noticed that when using the CTRL+MouseWheel shortcut that the zoom levels are bouncy, and after zooming in, you are unable to zoom back out completely. The issue persists until you exit that shell and close that tab. By bouncy, what I mean is when you zoom out (easiest to see how bad as zooming out shows the problem), the terminal text size will zoom in and out rapidly landing on larger font sizes more often than smaller ones. Zooming in is more stable as the font sizes appear to grow while landing on smaller font sizes much less frequently and if lucky, not at all.

Could you please correct this issue.

bgagnon 12-24-2018 08:57 AM

Hi microvb,

There is a pre-release build we believe resolves the issue reported.
  • Please send email to support@vandyke.com.

  • Please include "Bug Report - Forum Thread #13340" in the subject line.

  • If writing from the email address associated with your download account, we need nothing further.

  • However, if the email address used for your download account is different, please include that email address in the body of your email.


All times are GMT -6. The time now is 10:45 AM.