VanDyke Software Forums

VanDyke Software Forums (https://forums.vandyke.com/index.php)
-   Scripting (https://forums.vandyke.com/forumdisplay.php?f=14)
-   -   Multiple Instances preventing new instances from starting (https://forums.vandyke.com/showthread.php?t=14136)

cmiles4 04-02-2020 05:01 PM

Multiple Instances preventing new instances from starting
 
Hi,

I am using SecureCRT 8.3 on a Windows server with programs generating scripts and executing those scripts via the CLI using a CMD prompt. This is all done automatically by my systems with no manual intervention.

This system can generate numerous executions of SecureCRT simultaneously, each one in its own instance.

I have a problem in that sometimes (but not always) it appears that new instances are not starting when existing instances are still running.
Particularly, when some of the instances are not automatically quitting for various reasons (and I am working to address this).

My questions are:

1) Are there any known issues with SecureCRT that would prevent new instances opening when there are already multiple instances running and what are the conditions under which this might occur.

2) If I was to use the /T option when executing my scripts, would that create a new instance if one did not already exist, would it really add to an existing instance, and when a script Quits would it kill the entire instance (including all tabs) or would it close only the tab within the instance that it was running in?

I hope this all makes sense and I look forward to any help that can be provided.

Chris

bgagnon 04-03-2020 10:02 AM

Hi Chris,

There may be some troubleshooting we can do to determine the cause of the issue.

Please send an email to support@vandyke.com and include Forum Thread #14136 in the subject line.

Please include complete version number from the Help / About SecureCRT… dialog and the specific OS SecureCRT is installed on.


All times are GMT -6. The time now is 09:51 PM.