PDA

View Full Version : Backspace key prints ^H instead of backspacing


GamerX
11-22-2006, 04:06 AM
Hello again,

I found another problem with SecureCRT, this time I think it's not my configuration. When I connect to a linux shell (linux emulation), backspace does its function correctly on the shell prompt. The problem is that, on some process prompts (like rm removal confirmation, or a service configuration console), backspace prints ^H instead of deleting the last typed character:

[root@antispam ~]# rm .mysql_history
rm: remove regular file `.mysql_history'? y^H^H^H

This seems to happen on some shell interactive programs, but not on vi, yum... I have no idea on why this happens.

Thank you again!

tnygren
11-22-2006, 09:05 AM
Hi GamerX,

Some console utilities don't interpret the backspace character (^H) as a backspace and need a delete instead.

In this case, enabling the option 'Backspace sends delete' in the 'Mapped Keys' sub-category under 'Emulation' and 'Terminal' in the 'Session Options' should allow for the 'Backspace' key to function correctly without affecting how the command shell works.

Does this help?

GamerX
11-22-2006, 10:10 AM
Thank you Teresa, it worked like a charm. I already saw this option, but I wasn't quite sure of its functionality, so i didn't try it because of the previous experience (the interrupts issue).

Thank you again.

tnygren
11-22-2006, 01:46 PM
Hi GamerX,

I'm happy that this option helped! :)

I can understand not wanting to make changes in the session and accidentally resetting the session to cause the interrupt issue in Yum.

Let us know if you have any other questions.